Get in touch
Back
Downtime

Dashboard unavailable

Started 1 Nov at 07:06pm CET, resolved 1 Nov at 07:07pm CET.

Client portal
Resolved

Services have been recovered. We’re monitoring the situation.

Posted 1 Nov at 07:07pm CET.
Created

Our dashboard is currently unavailable our team is investigating.

Posted 1 Nov at 07:06pm CET.